Latest activity

  • Lowdownlancer
    Hi all, Im trying to source a cheap (yes, i know cheap means dodgy) light weight pully kits. May i please have some links? Thank you
  • JacksonRop2442
    JacksonRop2442 replied to the thread CH Lancer Rough start.
    Let me know how it goes tomorrow. My mates 1.8 did the exaxt same thing, I brought a set of known good coils and that got rid of it for...
  • JacksonRop2442
    JacksonRop2442 reacted to wagonmaster's post in the thread CH Lancer Rough start with Like Like.
    Will try that tomorrow and see what happens, didn't bother testing tps sensor as when i replaced it, all was good again, but yes i will...
  • wagonmaster
    wagonmaster replied to the thread CH Lancer Rough start.
    Will try that tomorrow and see what happens, didn't bother testing tps sensor as when i replaced it, all was good again, but yes i will...
  • JacksonRop2442
    JacksonRop2442 replied to the thread CH Lancer Rough start.
    That's true as well, but have you tested the TPS sensors to make sure that theyre actually dead/have failed? Try unplugging the MAF...
  • wagonmaster
    wagonmaster replied to the thread CH Lancer Rough start.
    Good thinking, Yes, that was was my second plan of attack after installing new fact TPS sensor, its all well and good testing on...
  • wagonmaster
    wagonmaster replied to the thread Coilovers Adjustment.
    The part numbers for your maxspeed coilover should be 0206-G-na-vg2 , yours should have front spring rating of 7KG/mm and the rears...
  • JacksonRop2442
    JacksonRop2442 replied to the thread CH Lancer Rough start.
    It's worth testing / putting a known good set of coils and a known good MAF into it to rule those out. I've helped two Mates of mine...
  • wagonmaster
    wagonmaster replied to the thread CH Lancer Rough start.
    Yes its a 2lt, new mitsi factory fuel pump, not showing any codes up on OBD1 code reader, I cleaned the MAF, coils and leads tested ok...
  • JacksonRop2442
    JacksonRop2442 replied to the thread CH Lancer Rough start.
    Is it a 2l? If it is it could potentially be the coils/leads as well as the MAF
  • wagonmaster
    wagonmaster replied to the thread Whip style aerial.
    https://www.ebay.com/sch/i.html?_from=R40&_trksid=p2380057.m570.l1313&_nkw=16%22+car+booster+radio+aerial&_sacat=0 You prob have one...
  • wagonmaster
    wagonmaster replied to the thread CH Lancer Rough start.
    Mine was the same, started 2 mths ago, would take 3-4 start attempts where it would splutter and try to start, it would start and run...
  • devastator99
    devastator99 reacted to Speed Merchant's post in the thread Weight Distribution with Like Like.
    Putting my car on the scales confirms the ratio Spetz stated.
  • Speed Merchant
    Speed Merchant replied to the thread Weight Distribution.
    Putting my car on the scales confirms the ratio Spetz stated.
  • Lowdownlancer
    That makes my life easier. Thank you
Top