Wiring issues

Steve99

Active Member
Hey all
Recently did a 1.8l conversion using wiring from a 2003 1.8l Coupe with all the interior and engine bay wiring from the same car
The ecu wiring is from my old 1.8l 1998 lancer and seems to work with a few minor errors
i have seen a few cut wires near the bcm fuse box near the driver kick panel.
Have also noticed a missing plug somewhere and have no idea what I have missed

so most of the things so far work, speedo, temperature, fuel gauge all work. Low and high beams work. Parks indicators work
The cabin lighting don’t work, they did once but stopped working

having issues with the horn not working. Checked connection fuses and relays and nothing work, no clicking or anything.

Head unit does not work at all, once it has turned on, then hasn’t worked again, all wiring fuses and relays have been checked and they all seems to be fine. Ground points are all good and sitting fine with no movement on the connections

climate control doesn’t work at all. Can move the dial for the heater but no fans, AC, or the rear demister all don’t work,

If any information is needed please ask :)
(Am quite bad with wiring, is why I’m asking)
Cheers all
58F28B64-4487-46BD-AB12-D3DEDA99BE02.jpeg
Cut wires from the previous owners.

F6092E7F-0E20-4DA7-ACA9-462EE4C9D8EC.jpegC64E456B-5C20-408D-B171-1116C97114B7.jpeg
only plug I couldn’t work out what it’s used for.
 

Grovermister

New Member
The cut wires look like old head unit wires ditto the plug...

I could be wrong...

bit hard to tell exactly where those wires are...

presuming you have a Haynes/Gregory manual with all the wiring layout for it?

you seem to have checked all the obvious locations fuses etc

maybe the internals of the wires themselves are 'nicked' and that is why some of the items worked and now don't....

will have to try to trace for continuity each wire for the various items that are not working... and replace the the individual wire as required.

*mum* of a job, good luck
 

Steve99

Active Member
Cheers mate
I’ll give it another go in a few days and see what I can do, I’ll try and chase up those cut wires.
Noticed the blue and orange wire has a plug, which I think is the dome light, but can’t find the other side of the plug, assuming it was butchered awhile back.
 

JacksonRop2442

Member
Lifetime Premium Member
Cheers mate
I’ll give it another go in a few days and see what I can do, I’ll try and chase up those cut wires.
Noticed the blue and orange wire has a plug, which I think is the dome light, but can’t find the other side of the plug, assuming it was butchered awhile back.
The dome light plugs into the BCM, in the top left side of it I think.Screenshot_20200902-090650_Gallery.jpg
 

Steve99

Active Member
Cheers mate
Although the wires from the loom have been cut and all *fudge*ed up. This is what it looks like. The small blue white wire has been cut and leads nowhere. The bigger blue white wire has also been cut and leads no where and another solid blue wire has the weird connection on it which goes nowhere aswell

78E2EA86-FA32-48AD-AA88-0182A80CEA5C.jpeg

I have power going to the12v socket, the clock illuminates but shows no time and the tacho still
One of the relays on the bcm click when I press the Demister button, but still no power to the fans, ac light comes on when pressed but nothing else

(Edit)
Still no luck after fixing the wiring. Assuming it’s a bad connection somewhere on the line, or I have a bigger issue. Which is what I’m thinking is the case
Guess it’s dash out and check all the grounds and wiring.... again
 
Last edited:

Steve99

Active Member
No luck with the wiring still soldered the connection on the wiring that was jank. Still no horn, head unit, dome lighting, if I press the demister the relays click at the bcm. Replaced all fuses and relays and still doesn’t work. If I press the ac button while fan settings are on the revs jump up slightly but still the fans don’t power on at all
And tacho still doesn’t seem to work, so I am at a brick wall in terms of what might be the culprit
 

Grovermister

New Member
...may have to bite the bullet and get an auto electrician in...

sheesh....

or...or replace individual wires... *mum* of a job... but can be done...

good luck
 

Steve99

Active Member
Going to swap over the other interior loom first. If not I’ll bite the bullet and go to an auto elec
*fudge* replacing every wire
Thanks for the suggestions guys :)
 
Top