4G15 Mirage won't rev

Discussion in 'CE Lancers and Mirages' started by CoopsTAS, Apr 23, 2018.

  1. CoopsTAS

    CoopsTAS New Member

    Hey guys i'm extremely new to this page just after some advice/help with my 2003 mirage...

    So I bought this car a couple days ago and it's been running like clock work until last night when a mate decided he'd try and be funny and pull 2 plug leads off.. Car hesitated to start at first then fired and ran rough obviously...
    So we put the plug leads back on and the car wouldn't start...

    So started back with the basics checked leads, fuel, injector pulse etc all was fine ended up tow starting the car and finally got it going but it wouldn't rev as soon as I apply throttle It'd want to die...
    So today I replaced the plugs and leads and it still wouldn't start until we tow started it again.. Still same issue it won't rev...
    Put a spark plug on the end of the lead and cranked it over and noticed the spark looked weak as in an orange spark as opposed to a blue spark...

    I hope I've given enough info and hoping someone can point me in the right direction as to where to go from here..
     
  2. donki

    donki Administrator Forum Administrator

    Check the leads going in to the dizzy, and check the points on the dizzy rotor. As youve changed plugs, no chance their fouled, and orange spark is a weak ignition. Also check the battery terminals and earthing points are tight.

    Edit: check you having knocked off any vac hose either
     
  3. CoopsTAS

    CoopsTAS New Member

    Everything seems to be in order with the above pulled dizzy cap off cleaned the contacts etc no hoses off that I can see once the car is going it idles as it should so I'm leaning more towards the distributor sode of things... I just want to try eliminating everything else before I buy a new distributor
     
  4. CoopsTAS

    CoopsTAS New Member

    Also if I feather the throttle I can get it up to 110km/h no sooner I apply more throttle it breaks down and misses/bogs down
     
  5. Shadow

    Shadow Member

    This may sound a bit dumb but have you tried a battery reset where you disconnect the battery completely and leave for about 5minutes, then reconnect, start the car and let the ECU re-learn what it needs to. Could be it's got a bad ignition setting from when it had only the 2 plugs in.
     
  6. CoopsTAS

    CoopsTAS New Member

    Yea I've tried that left it for about 10 mins and even turned headlights on to drain any remaining power out
     
  7. Shadow

    Shadow Member

    It does sound like the distributor section then. Sounds like it might be on its way out. Mine did similar things just before it died.
     
  8. CoopsTAS

    CoopsTAS New Member

    I'm leaning more towards that too... if I creep into the revs I can get it to the limiter but seems as soon as I put some sort of a load on it, it breaks down
     
  9. Zipper

    Zipper Member

    How about fuel? It sounds a bit like the fuel pump might not be working.
     
  10. CoopsTAS

    CoopsTAS New Member

    No it's pumping fuel can hear the pump engage and also confirmed by pulling line off at the fuel rail
     
  11. CoopsTAS

    CoopsTAS New Member

    So as stupid as this sounds I unplugged the fuel pump relay and it sounds like it wants to fire whilst unplugged... checked spark again still only getting a dull orange spark
     
  12. frosty7

    frosty7 Active Member

    Have you mixed up the firing order of the ignition leads???.
     
  13. CoopsTAS

    CoopsTAS New Member

    No everything seems to be in order is there a way to test the coil on these?
     

Share This Page